MD5
7d523592843e1c4a6d1f66108c8c33f4
SHA1
edf760faaeefcc2e6249049031b3346aa48957b8
  • Анонимно
  • Скачан 125 раз
  • Metalink
  • QR

Общее

Количество файлов: 1

Описание

Список значений в языке 1С 8.3, 8.2 (в примерах)

Вступайте в мою группу помощник программиста.
В ней мы обсуждаем программирование в 1С.

2017-05-02T14:21:30+00:00Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

ОбщиеОбъекты Запросы ПрикладныеОбъекты УниверсальныеФункции

См. урок для начинающих по списку значений в 1С
Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать)

Полный синтаксис (нажмите, чтобы раскрыть)

СписокЗначений

Описание:

Список значений - это не сохраняемый в базе данных объект, который позволяет строить для решения интерфейсных задач динамические наборы значений и манипулировать ими (добавлять, редактировать, удалять элементы, сортировать). Он может быть наполнен значениями любого типа, т.е. в одном списке типы хранимых значений могут быть разными. Одним из примеров использования данного объекта может служить организация выбора конкретного документа из списка возможных документов, сформированного по сложному алгоритму.

Элементы коллекции: ЭлементСпискаЗначений

Для объекта доступен обход коллекции посредством оператора Для каждого … Из … Цикл. При обходе выбираются элементы коллекции.

Возможно обращение к элементу коллекции посредством оператора [...]. В качестве аргумента передается индекс элемента (нумерация с 0).

Свойства:

ДоступныеЗначения Применяется в случаях, когда требуется ограничить возможность задания значений для элементов списка некоторым подмножеством значений допустимого типа (если для списка установлено описание типа). Неопределено - ограничения отсутствуют. Установка этого свойства влияет на работу диалога редактирования списка значений, элементов управления "Таблица" и "Поле ввода", связанных со списком значений, а также на программное добавление-вставку нового элемента списка значений и установку значений элементам списков.
ТипЗначения Определяет тип (см. ОписаниеТипов) для значений, которые могут храниться в элементах данного списка значений.

Методы:

Вставить(Индекс, Значение, Представление, Пометка, Картинка) Вставляет новый элемент в список значений на позицию с указанным индексом.
ВыбратьЭлемент(Заголовок, Элемент) Вызывает окно для интерактивного выбора одного из элементов, входящих в список значений. Элемент - элемент, на который следует изначально спозиционировать список значений при интерактивном выборе. Если значением параметра не является элемент списка значений, входящий в данный список, позиционирования не произойдет.
ВыгрузитьЗначения() Создает массив и копирует в него значения элементов списка значений.
Добавить(Значение, Представление, Пометка, Картинка) Добавляет новый элемент в конец списка значений.
ЗагрузитьЗначения(МассивЗначений) Загружает список значений значениями из переданного массива. При этом все прежние элементы списка удаляются.
ЗаполнитьПометки(Пометка) Устанавливает пометку у всех элементов списка значений.
Индекс(Элемент) Получает индекс элемента в списке значений. Если не найдено, то возвращается -1.
Количество() Получает количество элементов списка значений.
НайтиПоЗначению(ИскомоеЗначение) Осуществляет поиск значения элемента списка значений. Если ни один элемент не хранит значения, равного искомому, то возвращается значение Неопределено.
НайтиПоИдентификатору(Идентификатор) Получает элемент списка значений по идентификатору. Если элемент не найден, то возвращается Неопределено.
ОтметитьЭлементы(Заголовок) Устанавливает или снимает (интерактивно) пометки у элементов списка значений. Возвращает Истина, если в диалоге нажата кнопка "ОК", Ложь - в противном случае.
Очистить() Очищает список значений, удаляя из него все элементы.
ПоказатьВыборЭлемента( ОписаниеОповещенияОЗакрытии, Заголовок, Элемент) Вызывает окно для интерактивного выбора одного из элементов, входящих в список значений.
ПоказатьОтметкуЭлементов( ОписаниеОповещенияОЗакрытии, Заголовок) Предназначен для интерактивной установки состояний пометок у элементов списка значений.
Получить(Индекс) Получает значение по индексу. Работает аналогично оператору [].
Сдвинуть(Элемент, Смещение) Сдвигает элемент списка значений на заданное количество позиций вперед или назад.
Скопировать() Создает копию списка значений.
СортироватьПоЗначению(Направление) Сортирует список значений в порядке возрастания или убывания хранимых элементами значений. См. пример ниже.
СортироватьПоПредставлению( Направление) Сортирует список значений по возрастанию или по убыванию в алфавитном порядке представлений входящих в состав списка значений элементов. См. пример ниже.
Удалить(Элемент) Удаляет элемент из списка значений, где Элемент - индекс удаляемого элемента, либо сам элемент.

Конструкторы:

Новый СписокЗначений

Оглавление (нажмите, чтобы раскрыть)

&НаКлиенте Процедура ВыполнитьКод(Команда) /// Как создать список значений в 1с 8.3, 8.2 Список = Новый СписокЗначений; /// Как добавить элемент в список значений в 1с 8.3, 8.2 // параметры метода добавить: // - значение // - представление // - отметка (необ.) // - картинка (необ.) Список.Добавить( 1980, // значение элемента "Год рождения Васи" // представление ); Список.Добавить(1985, "Год рождения Юли"); // значения могут быть разных типов Список.Добавить("Полина", "Имя ребёнка"); /// Как вставить элемент в список значений в 1с 8.3, 8.2 // вставляем в позицию №2 (элементы нумеруются с 0) // элемент со значением 2010 и представлением // "Год рождения их совместной дочки" Список.Вставить(2, 2010, "Год рождения их совместной дочки"); /// Как обойти элементы списка значений в 1с 8.3, 8.2 Для Каждого Элемент Из Список Цикл Сообщить( Элемент.Представление + ": " + Строка(Элемент.Значение) ); КонецЦикла; /// Как очистить список значений в 1с 8.3, 8.2 Список.Очистить(); Список.Добавить("Понедельник"); Список.Добавить("Вторник"); Список.Добавить("Среда"); /// Как узнать количество элементов списка значений, а также /// получить элемент списка по его индексу в 1с 8.3, 8.2 // нумерация с нуля Для Индекс = 0 По Список.Количество() - 1 Цикл Сообщить(Список[Индекс]); КонецЦикла; /// Как найти элемент списка по его значению в 1с 8.3, 8.2 ЗначВторник = Список.НайтиПоЗначению("Вторник"); /// Как узнать индекс элемента в списке в 1с 8.3, 8.2 Сообщить(Список.Индекс(ЗначВторник)); // 1, так как нумерация с нуля /// Как отсортировать список по его значениям в 1с 8.3, 8.2 // было: понедельник, вторник, среда Список.СортироватьПоЗначению(НаправлениеСортировки.Убыв); // стало: среда, понедельник, вторник /// Как удалить элемент из списка значений в 1с 8.3, 8.2 // удаляем первый элемент // параметр: элемент списка // или индекс элемента // можно так Список.Удалить(Список[0]); // или так // Список.Удалить(0); /// Как сдвинуть элемент списка значений в 1с 8.3, 8.2 // сдвигаем нулевой элемент на одну позицию вперёд // было: понедельник вторник Список.Сдвинуть(0, 1); // стало: вторник понедельник /// Как сделать копию списка в 1с 8 КопияСписка = Список.Скопировать(); Цвета = Новый СписокЗначений; Цвета.Добавить("Красный"); Цвета.Добавить("Зелёный"); Цвета.Добавить("Синий"); /// Как выгрузить значения списка в массив в 1с 8.3, 8.2 МассивЦветов = Цвета.ВыгрузитьЗначения(); /// Как загрузить значения списка из массива в 1с 8.3, 8.2 Цвета.ЗагрузитьЗначения(МассивЦветов); КонецПроцедуры /// Как сделать немодальный выбор значения из списка /// значений в 1с 8.3, 8.2 &НаКлиенте Процедура КакСделатьНемодальныйВыборЗначения(Команда) Цвета = Новый СписокЗначений; Цвета.Добавить("Красный"); Цвета.Добавить("Зелёный"); Цвета.Добавить("Синий"); // процедура ПослеВыбораЭлемента определена чуть ниже ОповещениеПослеВыбораЭлемента = Новый ОписаниеОповещения( "ПослеВыбораЭлемента", ЭтотОбъект ); Цвета.ПоказатьВыборЭлемента( ОповещениеПослеВыбораЭлемента, "Выберите любимый цвет" ); КонецПроцедуры &НаКлиенте Процедура ПослеВыбораЭлемента(Элемент, Параметры) Экспорт Если Элемент <> Неопределено Тогда Сообщить(Элемент.Значение); КонецЕсли; КонецПроцедуры /// Как сделать немодальную отметку значений из списка /// значений в 1с 8.3, 8.2 &НаКлиенте Процедура КакСделатьНемодальнуюОтметкуЗначений(Команда) Цвета = Новый СписокЗначений; Цвета.Добавить("Красный"); Цвета.Добавить("Зелёный"); Цвета.Добавить("Синий"); // процедура ПослеОтметкиЭлементов определена чуть ниже ОповещениеПослеОтметкиЭлементов = Новый ОписаниеОповещения( "ПослеОтметкиЭлементов", ЭтотОбъект ); Цвета.ПоказатьОтметкуЭлементов( ОповещениеПослеОтметкиЭлементов, "Выберите любимые цвета" ); // а вот так можно разом установить все отметки // списка в определенное значение Цвета.ЗаполнитьПометки(Истина); КонецПроцедуры &НаКлиенте Процедура ПослеОтметкиЭлементов(Элементы, Параметры) Экспорт Если Элементы <> Неопределено Тогда Для Каждого Цвет Из Элементы Цикл Если Цвет.Пометка Тогда Сообщить(Цвет.Значение); КонецЕсли; КонецЦикла; КонецЕсли; КонецПроцедуры /// Как сделать модальный выбор значения из списка в 1с 8.3, 8.2 &НаКлиенте Процедура КакСделатьМодальныйВыборЗначения(Команда) Цвета = Новый СписокЗначений; Цвета.Добавить("Красный"); Цвета.Добавить("Зелёный"); Цвета.Добавить("Синий"); ВыбЦвет = Цвета.ВыбратьЭлемент("Выберите любимый цвет"); Если ВыбЦвет <> Неопределено Тогда Сообщить(ВыбЦвет.Значение); КонецЕсли; КонецПроцедуры /// Как сделать модальную отметку значений из списка /// значений в 1с 8.3, 8.2 &НаКлиенте Процедура КакСделатьМодальнуюОтметкуЗначений(Команда) Цвета = Новый СписокЗначений; Цвета.Добавить("Красный"); Цвета.Добавить("Зелёный"); Цвета.Добавить("Синий"); Если Цвета.ОтметитьЭлементы("Выберите любимые цвета") Тогда Для Каждого Цвет Из Цвета Цикл Если Цвет.Пометка Тогда Сообщить(Цвет.Значение); КонецЕсли; КонецЦикла; КонецЕсли; // а вот так можно разом установить все отметки // списка в определенное значение Цвета.ЗаполнитьПометки(Истина); КонецПроцедуры /// Скачать и выполнить эти примеры на компьютере

Скачать эти примеры в виде тестовой базы (как загрузить, как исследовать)

Список значений в языке 1С 8.3, 8.2 (в примерах)

Дата Если Массивы Математика Процедуры Строки Циклы
Диалоги ОписаниеТипов ОперационнаяСистема Приложение Соответствие
СписокЗначений Структура ТаблицаЗначений ФайловаяСистема Формат

ОбщиеОбъекты Запросы ПрикладныеОбъекты УниверсальныеФункции

С уважением, Владимир Милькин (школа 1С программистов).
Владимир Милькин
Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

Список файлов

Ссылка: Код для блога или сайта: Ссылка для форума: